Client Portal Outage

Incident Report for TCF Ventures

Resolved

This incident has been resolved.
Posted Mar 25, 2025 - 19:26 EDT

Identified

We have identified a critical outage in our client portal. Recovery efforts are in progress. Core services remain unaffected, but invoice payments and automatic renewals are unavailable at this time. Our team is working diligently to restore full functionality, and we will provide further updates as they become available. We apologize for any inconvenience and thank you for your patience.
Posted Mar 23, 2025 - 10:59 EDT
This incident affected: Client Portal.